Package akka

Class AkkaVersion


  • public class AkkaVersion
    extends java.lang.Object
    • Constructor Summary

      Constructors 
      Constructor Description
      AkkaVersion()  
    • Method Summary

      All Methods Static Methods Concrete Methods 
      Modifier and Type Method Description
      static void require​(java.lang.String libraryName, java.lang.String requiredVersion)
      Check that the version of Akka is a specific patch version or higher and throw an UnsupportedAkkaVersion exception if the version requirement is not fulfilled.
      static void require​(java.lang.String libraryName, java.lang.String requiredVersion, java.lang.String currentVersion)
      Internal API:
      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
    • Constructor Detail

      • AkkaVersion

        public AkkaVersion()
    • Method Detail

      • require

        public static void require​(java.lang.String libraryName,
                                   java.lang.String requiredVersion)
        Check that the version of Akka is a specific patch version or higher and throw an UnsupportedAkkaVersion exception if the version requirement is not fulfilled.

        For example: require("my-library", "2.5.4") would fail if used with Akka 2.4.19 and 2.5.3, but succeed with 2.5.4 and 2.6.1

        Parameters:
        libraryName - The name of the library or component requiring the Akka version, used in the error message.
        requiredVersion - Minimal version that this library works with
      • require

        public static void require​(java.lang.String libraryName,
                                   java.lang.String requiredVersion,
                                   java.lang.String currentVersion)
        Internal API:
        Parameters:
        libraryName - (undocumented)
        requiredVersion - (undocumented)
        currentVersion - (undocumented)