Akka Persistence Enhancements Release Notes

Version 1.1.12

  • Support Akka 2.6.x and 2.5.x.
  • Make Multi-DC Persistence compatible with Akka 2.6.x and 2.5.x.
  • Update to akka-persistence-cassandra 0.99.

Version 1.1.11

  • Update Jackson databind version to 2.9.9.3 (GDPR for Lagom)
  • Update link to credentials for dependencies

Version 1.1.10

  • Add support for running under Scala 2.13.0

Version 1.1.8, March 13, 2019

  • Updated dependencies to Akka 2.5.21.

Version 1.1.7, January 4, 2019

  • Updated dependencies to Akka 2.5.19 and akka-persistence-cassandra 0.92, which also updates the transitive dependency to Guava (older version has security vulnerability)